WORDPRESS5.2开始将要求PHP版本最低为5.6+

我就爱WORDPRESS

WORDPRESS官方最近发文通知,WORDPRESS5.2 将计划在4月底发布正式版,同时将要求PHP的最新版本为5.6.20,也就是说,如果你的PHP版本低于这个,你将无法安装或升级到5.2及以上版本!从WORDPRESS5.1开始,运行低于5.6的PHP版本的用户在其仪表板中有一个通知,其中包含帮助他们更新PHP的信息。从那时起,WORDPRESS统计数据显示,在最新版本的PHP上,用户数量有所增加。

为什么要更新PHP

如果您的站点在不受支持的PHP版本上运行,则WORDPRESS更新程序将不会向您的站点提供WORDPRESS5.2。如果您尝试手动更新WORDPRESS,该更新将失败。要继续使用WORDPRESS的最新功能,您必须更新到较新版本的PHP。

当更新到新版本的PHP时,WORDPRESS鼓励更新到推荐的PHP 7.3版本。PHP开发团队做得很好,越新的版本性能就越好。这意味着更新将提高您和访问者的网站速度。此性能提升还意味着托管网站所需的服务器更少。更新PHP不仅对您的网站有利,也意味着世界上使用WORDPRESS的三分之一的网站将需要更少的资源,对地球将更有益处!

如何更新PHP

其实现在国内的很多主机商的产品,都已经有提供7.0+的PHP了,所以,建议使用虚拟主机的朋友,联系主机商,问问在哪里可以修改当前的PHP版本。而对于使用云服务器的用户,就只能自己配置PHP满足对应的版本要求了。

此次PHP最低版本要求,是自2010年来的第一次更改,但是不会是2019的最后一次更改,预计在2019年底就可能将最低版本提高到PHP7.0+,所以,朋友们,是时候该升级你们的PHP啦!因为,要用最新版的WORDPRESS,那就只能升级PHP啦!!

不要再用万网/阿里云的虚拟主机啦!

阿里云目前提供的虚拟主机产品,就是收购了万网以后的东西,MYSQL版本居然还是5.1,实在是唏嘘!!!这么大一家公司的产品,居然还在使用类似于WINDOWS98级的老古董数据库版本!是不是要呼吁WORDPRESS也要强制要求将MYSQL升级到5.5+,如果不满足就不给安装!

本文由 我就爱WORDPRESS 作者:我就爱WORDPRESS 发表,其版权均为 我就爱WORDPRESS 所有,文章内容系作者个人观点,不代表 我就爱WORDPRESS 对观点赞同或支持。如需转载,请注明文章来源。
13
我就爱WORDPRESS

发表评论